Added Java Version to POM File

Release DateDec 10, 2018
Change Type
Platforms Affected

We have added information about the minimum required Java version to the pom.xml file in Java projects. The enforced version has not changed and is still Java 7. Previously if the user tried to use our Java SDK with a lower version, they would face compilation failure and receive error messages that were sometimes ambiguous. Now a Maven build failure is caused which clearly informs the user that the problem is with the version of Java being used. To benefit from this change, please generate your Java SDKs again.

Related Links


Have questions? Submit a request.